summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 378951072fa1..eaccc9894c32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,27 @@
# Contributor: evertonstz <evertonjcorreia@gmail.com>
# Contributor: phijor <mail [at] phijor [dot] me>
-_pkgname=iris
-pkgname=mopidy-${_pkgname}
-pkgver=3.64.0
+_name=Mopidy-Iris
+pkgname=mopidy-iris
+pkgver=3.69.3
pkgrel=1
pkgdesc='A Mopidy Web client that utilizes the Spotify and EchoNest frameworks. (Formerly Spotmop)'
arch=('any')
-url="https://github.com/jaedb/${_pkgname}"
+url="https://github.com/jaedb/iris"
license=('APACHE')
-depends=('mopidy>=3' 'python-configobj' 'python-pylast')
-makedepends=('python-setuptools' 'python-pip')
+depends=('mopidy>=3' 'python-pykka>=2.0.1' 'python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-wheel')
optdepends=('mopidy-local: local library support'
'mopidy-spotify: spotify support')
-source=("${pkgname}-${pkgver}.tar.gz::https://pypi.io/packages/source/M/Mopidy-Iris/Mopidy-Iris-${pkgver}.tar.gz")
-sha256sums=('6c0b4de663e39abb6ecbad38fcf22bad04cc864fabfec31e273d5848df385d18')
+source=("${_name}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('3c40179daa62cb1a338a3474e7723bcd061160b783395ef5f4bd106cedabe2be')
+
+build() {
+ cd "${_name}-$pkgver"
+ python -m build --wheel --no-isolation
+}
package() {
- cd "${srcdir}/Mopidy-Iris-${pkgver}"
- python setup.py install --root="${pkgdir}/" --optimize=1
+ cd "${_name}-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}