summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 4 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a4982717a8cf..972463ba39f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,20 @@
_pkgname=iris
pkgname=mopidy-${_pkgname}
-pkgver=3.8.9
+pkgver=3.9.0
pkgrel=1
pkgdesc='A Mopidy Web client that utilizes the Spotify and EchoNest frameworks. (Formerly Spotmop)'
arch=('any')
url="https://github.com/jaedb/${_pkgname}"
license=('APACHE')
depends=('python2' 'mopidy' 'mopidy-spotify' 'python2-configobj'
- 'mopidy-local-images' 'python2-pylast'
- 'python2-raven')
+ 'mopidy-local-images' 'python2-pylast' 'python2-raven')
makedepends=('python2' 'python2-setuptools' 'python2-pip')
optdepends=('mopidy-local-sqlite: local library support')
source=("https://files.pythonhosted.org/packages/source/M/Mopidy-Iris/Mopidy-Iris-${pkgver}.tar.gz")
-sha256sums=('13a13511d1404efd7df2526ad00f3995aab3e4b41cc63fe534944b286edbf2cf')
+sha256sums=('e4b000e33952c89e1ffe641dd3d9ba4eadb132b989990547ec99bf4c5fdd92a0')
package() {
cd "${srcdir}/Mopidy-Iris-${pkgver}"
- PIP_CONFIG_FILE=/dev/null pip2 install \
- --isolated \
- --root="${pkgdir}" \
- --ignore-installed \
- --no-deps .
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
}