summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 16 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 04077dfb1437..f3c899645025 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=mopidy-pandora
pkgver=1.1.1
-pkgrel=1
+pkgrel=2
pkgdesc="Mopidy extension for playing music from Pandora"
arch=("any")
url="https://github.com/mopidy/mopidy-pandora"
@@ -15,10 +15,21 @@ depends=(
"python-pykka"
"python-requests"
)
-source=("https://github.com/mopidy/mopidy-pandora/archive/v${pkgver}.tar.gz")
-sha256sums=("da1901fa0ee72181fb4607cb872cc7042beaf0a091ab2e5a44607bd733291dcc")
+#source=("https://github.com/mopidy/mopidy-pandora/archive/v${pkgver}.tar.gz")
+source=("https://pypi.io/packages/source/M/Mopidy-Pandora/Mopidy-Pandora-${pkgver}.tar.gz")
+sha256sums=("250adc721ad66a5904829d1c46b1dd6e6fc938c5bcf0b78e27ff1c75e89dafd2")
+
+build() {
+ cd "Mopidy-Pandora-${pkgver}"
+
+ python setup.py build
+}
package() {
- cd "mopidy-pandora-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1
+ cd "Mopidy-Pandora-${pkgver}"
+
+ PYTHONHASHSEED=0 python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+
+ install -Dm644 README.rst "${pkgdir}/usr/share/doc/mopidy-pandora/README.rst"
+ install -Dm644 AUTHORS "${pkgdir}/usr/share/doc/mopidy-pandora/AUTHORS"
}