summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 16 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..267682b4d127
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+pkgname=moro
+pkgver=4.1.1
+pkgrel=1
+pkgdesc="A command line tool for tracking work hours."
+arch=(any)
+url="https://github.com/omidfi/moro"
+license=('MIT')
+depends=('nodejs')
+makedepends=('npm')
+
+package() {
+ npm install -g --prefix "$pkgdir/usr" $pkgname@$pkgver
+ # Non-deterministic race in npm gives 777 permissions to random directories.
+ # See https://github.com/npm/npm/issues/9359 for details.
+ find "${pkgdir}"/usr -type d -exec chmod 755 {} +
+}