summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f6be4d204df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Contributor: Christian Neukirchen <chneukirchen@gmail.com>
+# Maintainer: ava1ar <mail(at)ava1ar(dot)me>
+
+pkgname=mosh-git
+pkgver=20150611
+pkgrel=1
+pkgdesc="Mobile shell, surviving disconnects with local echo and line editing, development version"
+arch=('i686' 'x86_64' 'arm')
+url="http://mosh.mit.edu/"
+license=('GPL3')
+depends=('protobuf' 'ncurses' 'zlib' 'openssh' 'perl' 'perl-io-tty' 'libutempter')
+makedepends=('git')
+optdepends=('perl-io-socket-ip: for IPv6 support'
+ 'vte-mosh-fix: to work properly in vte'
+ 'vte3-mosh-fix: to work properly in vte3')
+conflicts=('mosh')
+source=('git+https://github.com/keithw/mosh.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/mosh"
+ git log -1 --format="%cd" --date=short | sed 's|-||g'
+}
+
+build() {
+ cd "${srcdir}/mosh"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/mosh"
+ make DESTDIR="${pkgdir}" install
+ rmdir "${pkgdir}/usr/etc"
+}