summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 86aa795c7dcb..9f63e4f783b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
-# Maintainer: Andrew O'Neill <andrew at meanjollies dot com>
+# Maintainer: Andrew O'Neill <andrew at haunted dot sh>
# Contributor: Christian Krause ("wookietreiber") <christian.krause@mailbox.org>
pkgname=mothur
-pkgver=1.47.0
+pkgver=1.48.0
pkgrel=1
pkgdesc='A bioinformatics program for analyzing microbial communities.'
arch=('x86_64')
url='https://www.mothur.org/'
-license=('GPL3')
+license=('GPL-3.0-only')
depends=('boost-libs')
makedepends=('boost' 'hdf5')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/${pkgname}/${pkgname}/archive/v.${pkgver}.tar.gz")
-sha256sums=('b33a1d56476c729fe0f7070345712caaee6b3aa2e603953eec052e945b6f2eab')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/${pkgname}/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('9494406abd8d14b821782ab9db811f045ded9424f28f01234ee6764d4e78941d')
prepare() {
- cd "${pkgname}-v.${pkgver}"
+ cd "${pkgname}-${pkgver}"
# I hate this so much.
- sed -i '87d' source/mothur.h
+ sed -i '90d' source/mothur.h
sed -i '13 i \#include <memory>' source/writer.h
sed -i '17 i \#include "unistd.h"' source/utils.cpp
sed -i 's/skipUchime),/skipUchime), source\/,/g' Makefile
@@ -25,13 +25,13 @@ prepare() {
}
build() {
- cd "${pkgname}-v.${pkgver}"
+ cd "${pkgname}-${pkgver}"
make
}
package() {
- cd "${pkgname}-v.${pkgver}"
+ cd "${pkgname}-${pkgver}"
install -Dm755 mothur "${pkgdir}/usr/bin/mothur"
install -Dm755 uchime "${pkgdir}/usr/bin/uchime"