summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4ba1f150b330..86aa795c7dcb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Christian Krause ("wookietreiber") <christian.krause@mailbox.org>
pkgname=mothur
-pkgver=1.46.1
+pkgver=1.47.0
pkgrel=1
pkgdesc='A bioinformatics program for analyzing microbial communities.'
arch=('x86_64')
@@ -10,27 +10,28 @@ url='https://www.mothur.org/'
license=('GPL3')
depends=('boost-libs')
makedepends=('boost' 'hdf5')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/${pkgname}/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('29b500b3c92d726cde34922f697f2e47f0b7127d76d9a6fb167cc2b8ba3d00fd')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/${pkgname}/${pkgname}/archive/v.${pkgver}.tar.gz")
+sha256sums=('b33a1d56476c729fe0f7070345712caaee6b3aa2e603953eec052e945b6f2eab')
prepare() {
- cd "${pkgname}-${pkgver}"
+ cd "${pkgname}-v.${pkgver}"
# I hate this so much.
sed -i '87d' source/mothur.h
sed -i '13 i \#include <memory>' source/writer.h
+ sed -i '17 i \#include "unistd.h"' source/utils.cpp
sed -i 's/skipUchime),/skipUchime), source\/,/g' Makefile
sed -i 's/CXXFLAGS = -O3/CXXFLAGS = -O3 -std=c++11/' source/uchime_src/makefile
}
build() {
- cd "${pkgname}-${pkgver}"
+ cd "${pkgname}-v.${pkgver}"
make
}
package() {
- cd "${pkgname}-${pkgver}"
+ cd "${pkgname}-v.${pkgver}"
install -Dm755 mothur "${pkgdir}/usr/bin/mothur"
install -Dm755 uchime "${pkgdir}/usr/bin/uchime"