summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f961cf7c4034..4553dcf52a99 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Christian Krause ("wookietreiber") <christian.krause@mailbox.org>
pkgname=mothur
-pkgver=1.44.3
+pkgver=1.45.0
pkgrel=1
pkgdesc='A bioinformatics program for analyzing microbial communities.'
arch=('x86_64')
@@ -10,23 +10,24 @@ url='https://www.mothur.org/'
license=('GPL3')
depends=('boost-libs')
makedepends=('boost' 'hdf5')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/${pkgname}/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('a9825ccbb7f60b527f63c16e07f9dd45373bdc8ee65c8f2f0b45f8b2113b2e6f')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/${pkgname}/${pkgname}/archive/v.${pkgver}.tar.gz")
+sha256sums=('b22e1b4ba8686f4e77e6a55a30a1a1cb6490b651398b0756d84f80314f55aa70')
prepare() {
- cd "${pkgname}-${pkgver}"
+ cd "${pkgname}-v.${pkgver}"
- sed -i '86d' source/mothur.h
+ sed -i '87d' source/mothur.h
+ sed -i 's/skipUchime),/skipUchime), source\/,/g' Makefile
}
build() {
- cd "${pkgname}-${pkgver}"
+ cd "${pkgname}-v.${pkgver}"
make
}
package() {
- cd "${pkgname}-${pkgver}"
+ cd "${pkgname}-v.${pkgver}"
install -Dm755 mothur "${pkgdir}/usr/bin/mothur"
install -Dm755 uchime "${pkgdir}/usr/bin/uchime"