summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 769f56cf428e..74a59d0b631a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,14 +6,17 @@ arch=('x86_64')
url="http://www.autodesk.com/products/maya/overview"
license=('custom: unlimited')
depends=('libpng12' 'tcsh' 'libxp' 'openssl' 'libjpeg' 'libtiff')
-makedepends=('rpmextract')
+makedepends=('rpmextract' 'gcc')
conflicts=()
install=maya.install
-source=(http://download.autodesk.com/us/support/files/maya_2016_service_pack_5/Autodesk_Maya_2016_SP5_EN_Linux_64bit.tgz)
+source=('http://download.autodesk.com/us/support/files/maya_2016_service_pack_5/Autodesk_Maya_2016_SP5_EN_Linux_64bit.tgz')
md5sums=('5b88676c1c3239ea26b9de656340e974')
package() {
+ install "$pkgdir"/opt/Autodesk/MayaSetup
+ rsync -av --exclude='*.rpm' ./ "$pkgdir"/opt/Autodesk/MayaSetup
+
cd "$pkgdir"
msg2 "Unpacking Red Hat .rpm files. This could take a while..."
@@ -23,5 +26,9 @@ package() {
rpmextract.sh $i
done
+ mv "$pkgdir"/usr/local/bin/maya "$pkgdir"/usr/local/bin/oriMaya
+
+ cp "$srcdir"/maya_start.sh "$pkgdir"/usr/local/bin/maya
+
}