summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b8fb3f7c3160..7aedda69df72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Guillaume Maudoux <layus DOT on @AT@ gmail DOT com>
pkgname=mozart2-git
-pkgver=v2.0.0.alpha.0.4166.g224deca
+pkgver=v2.0.0.alpha.0.4180.g7bdb820
pkgrel=1
pkgdesc="The Mozart Programming System version 2"
arch=('i686' 'x86_64')
@@ -16,11 +16,9 @@ install="${pkgname}.install"
source=(
"$pkgname::git+https://github.com/mozart/mozart2"
'git+https://github.com/mozart/mozart2-stdlib'
+ 'git+https://github.com/google/googletest'
)
-sha256sums=(
- 'SKIP'
- 'SKIP'
-)
+sha256sums=('SKIP' 'SKIP' 'SKIP')
pkgver() {
cd "$pkgname"
@@ -32,6 +30,7 @@ prepare() {
git submodule init
git config submodule.stdlib.url $srcdir/mozart2-stdlib
+ git config submodule.gtest.url $srcdir/googletest
git submodule update
# Add required libraries to executable.
@@ -57,11 +56,6 @@ build() {
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr/ \
-DMOZART_BOOST_USE_STATIC_LIBS=OFF \
- -DGTEST_BUILD_DIR=/usr/lib/ \
- -DGTEST_SRC_DIR=/usr/include/gtest/ \
- -DLLVM_BUILD_DIR=/usr/ \
- -DLLVM_SRC_DIR=/usr/ \
- -DCMAKE_CXX_FLAGS=-Wno-braced-scalar-init \
.
make #VERBOSE=1