summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 87eff6e542b4..6fdf999e70d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,17 @@
# Contributor: Felix Yan <felixonmars@gmail.com>
# Contributor: ponsfoot <cabezon dot hashimoto at gmail dot com>
-
pkgname='mozc'
-pkgver=2.26.4632.102
+pkgver=2.26.4646.102
pkgrel=1
pkgdesc='The Open Source edition of Google Japanese Input'
arch=('x86_64')
url='https://github.com/google/mozc'
license=('Apache' 'BSD' 'LGPL' 'custom')
depends=('qt5-base')
-makedepends=('bazel' 'git' 'pkgconf' 'python-six')
-conflicts=('mozc-ut-common' 'mozc-ut' 'mozc-ut2' 'mozc-ut-united' 'mozc-neologd-ut+ut2')
-source=("${pkgname}-git::git+https://github.com/google/mozc.git#commit=7329757e1ad30e327c1ae823a8302c79482d6b9c")
+makedepends=('bazel' 'git' 'python')
+conflicts=('mozc-ut-common' 'mozc-ut' 'mozc-ut-united')
+source=("${pkgname}-git::git+https://github.com/google/mozc.git#commit=cdb6ca32615805af5d2b7aa1dc5a9b300ae1b09f")
sha256sums=('SKIP')
prepare() {
@@ -34,7 +33,7 @@ prepare() {
build() {
cd ${pkgname}-git/src
- env PATH="/usr/lib/jvm/java-11-openjdk/bin/:$PATH" bazel build server:mozc_server gui/tool:mozc_tool --config oss_linux --compilation_mode opt
+ env PATH="/usr/lib/jvm/java-11-openjdk/bin/:$PATH" bazel build server:mozc_server gui/tool:mozc_tool --config oss_linux --compilation_mode opt --copt=-fPIC
}
package() {