summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6fdf999e70d6..1dd150566a93 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: ponsfoot <cabezon dot hashimoto at gmail dot com>
pkgname='mozc'
-pkgver=2.26.4646.102
+pkgver=2.26.4656.102
pkgrel=1
pkgdesc='The Open Source edition of Google Japanese Input'
arch=('x86_64')
@@ -12,17 +12,19 @@ url='https://github.com/google/mozc'
license=('Apache' 'BSD' 'LGPL' 'custom')
depends=('qt5-base')
makedepends=('bazel' 'git' 'python')
-conflicts=('mozc-ut-common' 'mozc-ut' 'mozc-ut-united')
-source=("${pkgname}-git::git+https://github.com/google/mozc.git#commit=cdb6ca32615805af5d2b7aa1dc5a9b300ae1b09f")
+optdepends=('fcitx5-mozc-ut: Fcitx5 integration'
+ 'fcitx-mozc-ut: Fcitx integration'
+ 'ibus-mozc: IBus integration'
+ 'emacs-mozc: Emacs integration')
+conflicts=('mozc-ut')
+source=("${pkgname}-git::git+https://github.com/google/mozc.git#commit=0dcb977536385e18f88e29b3ae42b07fd5f5f433")
sha256sums=('SKIP')
prepare() {
- cd ${pkgname}-git
+ cd ${pkgname}-git/src
git submodule update --init --recursive
- cd src
-
# Fix the Qt5 include path
sed -i -e 's/x86_64-linux-gnu\/qt5/qt/' config.bzl
@@ -33,7 +35,8 @@ prepare() {
build() {
cd ${pkgname}-git/src
- env PATH="/usr/lib/jvm/java-11-openjdk/bin/:$PATH" bazel build server:mozc_server gui/tool:mozc_tool --config oss_linux --compilation_mode opt --copt=-fPIC
+ export JAVA_HOME='/usr/lib/jvm/java-11-openjdk/'
+ bazel build server:mozc_server gui/tool:mozc_tool --config oss_linux --compilation_mode opt
}
package() {