summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 10 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 82f26518e2b6..e1396a57962e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
# Contributor: Felix Yan <felixonmars@gmail.com>
# Contributor: ponsfoot <cabezon dot hashimoto at gmail dot com>
-# NOTE: This PKGBUILD is based on https://osdn.net/downloads/users/30/30473/fcitx-mozc-ut-20210524.1.PKGBUILD
+# NOTE: This PKGBUILD is based on https://osdn.net/downloads/users/30/30561/fcitx-mozc-ut-20210603.PKGBUILD
# Mozc compile option
_bldtype=Release
-_mozcver=2.26.4381.102
+_mozcver=2.26.4388.102
_fcitxver=20210329
-_utdicver=20210524
+_utdicver=20210603
pkgver=${_mozcver}.${_utdicver}
pkgrel=1
@@ -26,37 +26,34 @@ conflicts=('fcitx-mozc' 'mozc' 'fcitx-mozc-ut2' 'mozc-ut2' 'fcitx-mozc-neologd-u
source=(
https://osdn.net/users/utuhiro/pf/utuhiro/dl/mozc-${_mozcver}.tar.bz2
- abseil-cpp-20200923.2.tar.gz::https://github.com/abseil/abseil-cpp/archive/20200923.2.tar.gz
+ abseil-cpp-20210324.1.tar.gz::https://github.com/abseil/abseil-cpp/archive/refs/tags/20210324.1.tar.gz
googletest-release-1.10.0.tar.gz::https://github.com/google/googletest/archive/release-1.10.0.tar.gz
japanese-usage-dictionary-master.zip::https://github.com/hiroyuki-komatsu/japanese-usage-dictionary/archive/master.zip
protobuf-3.13.0.tar.gz::https://github.com/protocolbuffers/protobuf/archive/v3.13.0.tar.gz
- https://osdn.net/users/utuhiro/pf/utuhiro/dl/mozcdic-ut-${_utdicver}.${pkgrel}.tar.bz2
+ https://osdn.net/users/utuhiro/pf/utuhiro/dl/mozcdic-ut-${_utdicver}.tar.bz2
https://www.post.japanpost.jp/zipcode/dl/kogaki/zip/ken_all.zip
https://www.post.japanpost.jp/zipcode/dl/jigyosyo/zip/jigyosyo.zip
- fix-abseil-cpp-build-gcc11.patch::https://yanqiyu.fedorapeople.org/fcitx5-mozc/fix-build-gcc11.patch
)
sha256sums=(
- '4ee389b22aa171f9730e2de68e9231a22cd82b709f1b5c81984b6ead6158b281'
- 'bf3f13b13a0095d926b25640e060f7e13881bd8a792705dd9e161f3c2b9aa976'
+ '077d0fa8f5259a40916f2bb498d87e3efd8e92621461f898112497ad32167df8'
+ '441db7c09a0565376ecacf0085b2d4c2bbedde6115d7773551bc116212c2a8d6'
'9dc9157a9a1551ec7a7e43daea9a694a0bb5fb8bec81235d8a1e6ef64c716dcb'
'e46b1c40facbc969b7a4af154dab30ab414f48a0fdbe57d199f912316977ac25'
'9b4ee22c250fe31b16f1a24d61467e40780a3fbb9b91c3b65be2a376ed913a1a'
- '32563ddc71a50716f907452bed600caa236db7271a7f3966a42df1be6d10a4ae'
+ '46303f6d2ecc77a990834d5ae0607b52a4e7cb8cc512fc9f266861d777b4c192'
'SKIP'
'SKIP'
- '2b1a14993dbf6c16601c495b55fab3c7ff50d3260a79514d8fb1dbd53b602dca'
)
prepare() {
cd mozc-${_mozcver}
rm -rf src/third_party
mkdir src/third_party
- mv ${srcdir}/abseil-cpp-20200923.2 src/third_party/abseil-cpp
+ mv ${srcdir}/abseil-cpp-20210324.1 src/third_party/abseil-cpp
mv ${srcdir}/googletest-release-1.10.0 src/third_party/gtest
mv ${srcdir}/japanese-usage-dictionary-master src/third_party/japanese_usage_dictionary
mv ${srcdir}/protobuf-3.13.0 src/third_party/protobuf
- patch -Np1 -i ${srcdir}/fix-abseil-cpp-build-gcc11.patch
# Add ZIP code
cd src/data/dictionary_oss/
@@ -69,7 +66,7 @@ prepare() {
sed "/stdlib=libc++/d;/-lc++/d" -i src/gyp/common.gypi
# Add UT dictionary
- cat ${srcdir}/mozcdic-ut-${_utdicver}.${pkgrel}/mozcdic*-ut-*.txt >> src/data/dictionary_oss/dictionary00.txt
+ cat ${srcdir}/mozcdic-ut-${_utdicver}/mozcdic*-ut-*.txt >> src/data/dictionary_oss/dictionary00.txt
}
build() {