summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 6 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fdc21f1d2c0b..e366e8aca0cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,22 +23,22 @@ _bldtype=Release
# https://osdn.net/users/utuhiro/pf/utuhiro/files/
#*************************************************************
-_mozcver=2.28.4740.102
-_utdicdate=20220525
+_mozcver=2.28.4960.102
+_utdicdate=20230107
_utdicver=1
pkgbase=mozc-ut-united
pkgname=mozc-ut-united
true && pkgname=('mozc-ut-united')
-pkgver=2.28.4740.102_20220525_2.26.4660.102.r163.g73f28998
+pkgver=2.28.4960.102_20230107_2.28.4880.102.r161.g7ec82c93
pkgrel=1
arch=('i686' 'x86_64')
url="https://code.google.com/p/mozc/"
url="https://osdn.net/users/utuhiro/pf/utuhiro/files/"
license=('BSD' 'GPL' 'custom')
makedepends=('ruby' 'git' 'ninja' 'clang' 'zinnia' 'bazel' 'python-six')
-source=("mozc::git+https://github.com/google/mozc.git" "https://osdn.net/downloads/users/38/38446/mozcdic-ut-${_utdicdate}.tar.bz2" "config-arch-new.patch" "git+https://chromium.googlesource.com/breakpad/breakpad" "git+https://github.com/google/googletest.git" "git+https://chromium.googlesource.com/external/gyp" "git+https://github.com/hiroyuki-komatsu/japanese-usage-dictionary.git" "git+https://github.com/open-source-parsers/jsoncpp.git" "git+https://github.com/protocolbuffers/protobuf" "git+https://github.com/abseil/abseil-cpp.git" "android-fix.patch")
-sha1sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
+source=("mozc::git+https://github.com/google/mozc.git" "https://osdn.net/downloads/users/40/40080/mozcdic-ut-${_utdicdate}.tar.bz2" "git+https://chromium.googlesource.com/breakpad/breakpad" "git+https://github.com/google/googletest.git" "git+https://chromium.googlesource.com/external/gyp" "git+https://github.com/hiroyuki-komatsu/japanese-usage-dictionary.git" "git+https://github.com/open-source-parsers/jsoncpp.git" "git+https://github.com/protocolbuffers/protobuf" "git+https://github.com/abseil/abseil-cpp.git")
+sha1sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
if [[ "$_emacs_mozc" == "yes" ]]; then
@@ -71,15 +71,10 @@ prepare() {
git config submodule.jsoncpp.url "$srcdir/jsoncpp"
git config submodule.protobuf.url "$srcdir/protobuf"
git config submodule.abseil-cpp.url "$srcdir/abseil-cpp"
- git submodule update
+ git -c protocol.file.allow=always submodule update
# Add UT dictionary
cat ${srcdir}/mozcdic-ut-${_utdicdate}/mozcdic*-ut-*.txt >> src/data/dictionary_oss/dictionary00.txt
-
- #fixes file include locations for ibus, and gtk along with correcting qt location on arch
- patch -d "${srcdir}/mozc/src" -i "${srcdir}/config-arch-new.patch"
- patch -d "${srcdir}/mozc/src" -i "${srcdir}/android-fix.patch"
-
}
build() {