summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 12 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 38334dcc91c7..ed9b69054dcd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,27 @@
# Contributor : Draje <draje@nullsum.net>
pkgname=mp3fs-git
-pkgver=20150913
+pkgver=20191117
pkgrel=1
pkgdesc="A read-only FUSE filesystem which transcodes audio formats (currently FLAC) to MP3 on the fly when opened and read."
-arch=('i686' 'x86_64')
+arch=("x86_64")
url="http://khenriks.github.com/mp3fs/"
-license=('GPL')
-depends=('fuse' 'flac' 'lame' 'libid3tag')
-makedepends=('git' 'asciidoc')
-conflicts=('mp3fs')
+license=("GPL")
+depends=("fuse" "flac" "lame" "libid3tag")
+makedepends=("git" "asciidoc")
+conflicts=("mp3fs")
source=('git://github.com/khenriks/mp3fs.git')
sha256sums=('SKIP')
build() {
- cd "$srcdir/mp3fs"
+ cd "$srcdir/mp3fs"
- ./autogen.sh
- ./configure --prefix=/usr \
- --without-vorbis-picture # There is no package for libb64 in Arch Linux as of today
- make || return 1
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make || return 1
}
package() {
- cd "$srcdir/mp3fs"
- make PREFIX=/usr sysconfdir=/etc localstatedir=/var DESTDIR="$pkgdir" install
+ cd "$srcdir/mp3fs"
+ make PREFIX=/usr sysconfdir=/etc localstatedir=/var DESTDIR="$pkgdir" install
}