summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index acba2bf5dce7..2242e03ad299 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,17 +8,21 @@ pkgver=1.5
pkgrel=3
pkgdesc="A program for computing the band structures and electromagnetic modes"
arch=('i686' 'x86_64')
-url="http://ab-initio.mit.edu/wiki/index.php/MIT_Photonic_Bands"
+url="https://mpb.readthedocs.io"
license=('GPL')
depends=('lapack' 'hdf5' 'fftw-mpi' 'libctl' 'openmpi')
makedepends=('gcc-fortran')
-source=(http://ab-initio.mit.edu/$pkgname/$pkgname-$pkgver.tar.gz)
-md5sums=('ea4dfe6dfdabb054d6332316903cff9f')
-sha256sums=('3deafe79185eb9eb8a8fe97d9fe51624221f51c1cf4baff4b4a7242c51130bd7')
+source=(git+https://github.com/stevengj/$pkgname.git)
+sha256sums=('SKIP')
-build() {
- cd "$srcdir"
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ git describe --long --tags | cut -d- -f1
+}
+build() {
+ cd "${srcdir}/${pkgname}"
+ git checkout ${pkgver}
cp -r $pkgname-$pkgver $pkgname-$pkgver-inv
cp -r $pkgname-$pkgver $pkgname-$pkgver-mpi
cp -r $pkgname-$pkgver $pkgname-$pkgver-inv-mpi
@@ -81,4 +85,4 @@ package() {
cd "$srcdir"/$pkgname-$pkgver-inv-mpi
make prefix="$pkgdir"/usr mandir="$pkgdir"/usr/share/man install
}
-#
+