summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 775481792ee1..284a446397b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -94,7 +94,7 @@ build() {
--enable-daemon \
--enable-sqlite \
--enable-icu \
- --disable-systemd-daemon \
+ --enable-systemd-daemon \
--with-systemduserunitdir=/usr/lib/systemd/user \
--without-systemdsystemunitdir \
--with-zeroconf=no
@@ -105,4 +105,6 @@ package() {
cd ${_pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install
+ sed -e 's/network.target //g' -e 's/AF_INET AF_INET6 AF_UNIX AF_NETLINK/AF_UNIX/g' -i "${pkgdir}"/usr/lib/systemd/user/mpd.service
+
}