summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 21da77e0f448..f27791d51ee8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,26 @@
# Maintainer: Alexander Kobel <a-kobel@a-kobel.de>
pkgname=mpsolve
-pkgver=3.1.4
-pkgrel=4
+pkgver=3.1.7
+pkgrel=1
pkgdesc="Multiprecision rootfinder for complex roots of univariate polynomials"
url="http://numpi.dm.unipi.it/software/mpsolve"
arch=('i686' 'x86_64')
license=('GPL')
depends=('gmp' 'mpfr')
+makedepends=('gcc-fortran')
optdepends=('cython: Python bindings'
+ 'doxygen: documentation (optional build-time dependency)'
'gtk3: Graphical debugger'
'octave: Octave bindings'
'qt4: Graphical interface xmpsolve')
+options=(!libtool)
source=("http://numpi.dm.unipi.it/_media/software/${pkgname}/${pkgname}-${pkgver}.tar.bz2")
-sha256sums=('c6ea3774bbcb50865f65426761e398861bc448697c563bcd46e551c81c4f70ad')
+sha256sums=('3e3d750ad3acc1f274015d0c418d3d6fadf5ed3aa1fc57680dd38b994d2e8305')
build () {
cd ${srcdir}/${pkgname}-${pkgver}
- ./configure --prefix=/usr --disable-debug-build
+ ./configure --prefix=/usr --disable-debug
make
}
@@ -29,6 +32,7 @@ check () {
package () {
cd ${srcdir}/${pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install
+
if [ -f ${pkgdir}/usr/share/octave/octave_packages ]; then
sed -e "s/$(echo "${pkgdir}" | sed -e 's/[\/&]/\\&/g')//g" -i ${pkgdir}/usr/share/octave/octave_packages
fi