summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 51394f41b7e6..34f58620682d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Alexander Kobel <a-kobel@a-kobel.de>
pkgname=mpsolve-git
-pkgver=3.1.6
-pkgrel=2
+pkgver=3.2.1.r12.g90f4999
+pkgrel=1
pkgdesc="Multiprecision rootfinder for complex roots of univariate polynomials"
url="http://numpi.dm.unipi.it/software/mpsolve"
arch=('i686' 'x86_64')
@@ -10,13 +10,12 @@ license=('GPL')
depends=('gmp' 'mpfr')
optdepends=('cython: Python bindings'
'gtk3: Graphical debugger'
- 'octave: Octave bindings'
- 'qt4: Graphical interface xmpsolve')
+ 'qt5-base: Graphical interface xmpsolve')
makedepends=('git' 'gcc-fortran')
options=(!libtool)
provides=('mpsolve')
conflicts=('mpsolve')
-source=("git://github.com/robol/MPSolve.git")
+source=("git+https://github.com/robol/MPSolve.git")
sha256sums=('SKIP')
pkgver () {
@@ -25,22 +24,23 @@ pkgver () {
}
build () {
- cd ${srcdir}/MPSolve
+ cd "${srcdir}/MPSolve"
./autogen.sh
- ./configure --prefix=/usr --disable-debug-build
+ ./configure --prefix=/usr --disable-debug-build --disable-examples
make
}
check () {
- cd ${srcdir}/MPSolve
+ cd "${srcdir}/MPSolve"
make check
}
package () {
- cd ${srcdir}/MPSolve
+ cd "${srcdir}/MPSolve"
make DESTDIR="${pkgdir}" install
- if [ -f ${pkgdir}/usr/share/octave/octave_packages ]; then
- sed -e "s/$(echo "${pkgdir}" | sed -e 's/[\/&]/\\&/g')//g" -i ${pkgdir}/usr/share/octave/octave_packages
+
+ if [ -e doc/html ]; then
+ cd doc/html
+ find . -type f -exec install -D -m644 "{}" "${pkgdir}/usr/share/doc/${pkgname}/{}" \;
fi
- install -D -m644 -t "${pkgdir}/usr/share/doc/${pkgname}" doc/html/*
}