summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f1f5cf571f38..91eb7d088fd8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -82,6 +82,9 @@ backup=('etc/mpv/encoding-profiles.conf')
if [ -f /usr/lib/libvapoursynth.so ]; then
depends+=('vapoursynth')
fi
+if [ -f /usr/lib/libavisynth.so.*.*.* ]; then
+ depends+=('avisynthplus-git')
+fi
pkgver() {
cd mpv
@@ -108,8 +111,10 @@ prepare() {
'--enable-libpulse'
'--enable-nonfree'
'--enable-cuda'
- '--enable-avisynth'
)
+if [ -f /usr/lib/libavisynth.so.*.*.* ]; then
+ _ffmpeg_options+=('--enable-avisynth')
+fi
_mpv_options=(
'--prefix=/usr'
'--confdir=/etc/mpv'