summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD67
1 files changed, 36 insertions, 31 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2a2bc56fbc3f..15558482b3eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,44 +5,47 @@ pkgver=v0.27.0.308.g3413fe4dfd
pkgrel=1
pkgdesc="Video player based on MPlayer/mplayer2 (uses statically linked ffmpeg). (GIT version)"
arch=('i686' 'x86_64' )
-depends=('desktop-file-utils'
+depends=(
+ 'desktop-file-utils'
+ 'fribidi'
'hicolor-icon-theme'
- 'libxv'
- 'libcdio-paranoia'
- 'openal'
- 'luajit'
- 'libssh'
- 'libcaca'
- 'rsound'
- 'libxss'
- 'libdvdnav'
'jack2'
+ 'lcms2'
+ 'libarchive'
'libbluray.so'
- 'libpulse'
'libbs2b'
+ 'libcaca'
+ 'libcdio-paranoia'
+ 'libdvdnav'
'libgme'
+ 'libmysofa'
+ 'libpulse'
+ 'libsoxr'
+ 'libssh'
+ 'libva'
+ 'libvdpau'
'libxinerama'
- 'libxrandr'
'libxkbcommon'
- 'sdl2'
- 'lcms2'
- 'libva'
- 'fribidi'
+ 'libxrandr'
+ 'libxss'
+ 'libxv'
+ 'luajit'
+ 'mujs'
+ 'openal'
+ 'rsound'
'rubberband'
+ 'sdl2'
+ 'shaderc-git'
+ 'smbclient'
'uchardet'
- 'libarchive'
- 'libsoxr'
'v4l-utils'
- 'libvdpau'
- 'libmysofa'
- 'mujs'
'vulkan-icd-loader'
- 'shaderc-git'
'xdg-utils'
)
license=('GPL2' 'GPL3' 'LGPL3' 'LGPL2.1' 'BSD')
url='http://mpv.io'
-makedepends=('git'
+makedepends=(
+ 'git'
'python-docutils'
'nasm'
'ladspa'
@@ -50,10 +53,11 @@ makedepends=('git'
'vulkan-headers'
'wayland-protocols'
)
-optdepends=('youtube-dl: Another way to view youtuve videos with mpv'
- 'zsh-completions: Additional completion definitions for Zsh users'
+optdepends=(
'mpv-bash-completion-git: Additional completion definitions for Bash users'
'nvidia-utils: for hardware accelerated video decoding with CUDA'
+ 'youtube-dl: Another way to view youtuve videos with mpv'
+ 'zsh-completions: Additional completion definitions for Zsh users'
)
provides=('mpv')
conflicts=('mpv')
@@ -96,13 +100,13 @@ prepare() {
# Set ffmpeg/libass/mpv flags
_ffmpeg_options=(
'--disable-programs'
- '--enable-nonfree'
- '--enable-libssh'
'--enable-ladspa'
'--enable-libbs2b'
'--enable-libgme'
'--enable-libmysofa'
'--enable-libsoxr'
+ '--enable-libssh'
+ '--enable-nonfree'
)
_mpv_options=(
'--prefix=/usr'
@@ -113,16 +117,17 @@ prepare() {
'--disable-vapoursynth-lazy'
'--lua=luajit'
'--enable-cdda'
+ '--enable-dvbin'
'--enable-dvdnav'
'--enable-dvdread'
+ '--enable-html-build'
+ '--enable-libarchive'
'--enable-libmpv-shared'
+ '--enable-libsmbclient'
'--enable-openal'
'--enable-sdl2'
- '--enable-zsh-comp'
- '--enable-libarchive'
- '--enable-html-build'
'--enable-tv'
- '--enable-dvbin'
+ '--enable-zsh-comp'
)
if [ ${_enable_cuda} = "1" ]; then