summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-x[-rw-r--r--]PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 43890a335429..004787e8f353 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -48,8 +48,9 @@ _opt_features=(
pkgname=mpv-git
_gitname=mpv
-pkgver=0.28.0_605_gcb52cfae1a
+pkgver=0.29.0_19_g6c2d6a3046
pkgrel=1
+_waf_version=2.0.9
pkgdesc='Video player based on MPlayer/mplayer2 (git version)'
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
license=('GPL')
@@ -63,11 +64,11 @@ conflicts=('mpv')
options=('!emptydirs')
install=mpv.install
source=('git+https://github.com/mpv-player/mpv'
- 'find-deps.py')
-md5sums=('SKIP'
- 'ffb774b13decbefc62908dda0332046b')
+ 'find-deps.py'
+ "https://waf.io/waf-${_waf_version}")
sha256sums=('SKIP'
- 'ce974e160347202e0dc63f6a7a5a89e52d2cc1db2d000c661fddb9dc1d007c02')
+ 'ce974e160347202e0dc63f6a7a5a89e52d2cc1db2d000c661fddb9dc1d007c02'
+ '2a8e0816f023995e557f79ea8940d322bec18f286917c8f9a6fa2dc3875dfa48')
# vulkan-icd-loader contains vulkan.pc, which makes mpv think it can build
# against Vulkan. However, the headers required to actually do so are in another
@@ -141,7 +142,8 @@ pkgver() {
prepare() {
cd "$srcdir/$_gitname"
- ./bootstrap.py
+ install -m755 "${srcdir}/waf-${_waf_version}" waf
+ ./bootstrap.py --no-download
}
build() {