summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3a0c4538bd16..7bf158badc06 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,18 +11,20 @@
pkgname=mpv-rpi
_pkgname=mpv
epoch=1
-pkgver=0.27.0
-pkgrel=2
-_waf_version=1.8.12
+pkgver=0.27.1
+pkgrel=1
+_waf_version=1.9.8
pkgdesc='mpv with Raspberry Pi support'
arch=('armv6h' 'armv7h' 'aarch64')
-license=('GPL')
-url='http://mpv.io'
+# We link against libraries that are licensed GPLv3 explicitly, libsmbclient
+# being one of these. So our package is GPLv3 only as well.
+license=('GPL3')
+url='https://mpv.io/'
depends=(
'ffmpeg-mmal' 'lcms2' 'libcdio-paranoia' 'libgl' 'libxss'
'libxinerama' 'libxv' 'libxkbcommon' 'libva' 'wayland' 'libcaca'
'desktop-file-utils' 'hicolor-icon-theme' 'xdg-utils' 'lua52' 'libdvdnav'
- 'libxrandr' 'jack' 'rubberband' 'uchardet' 'libarchive'
+ 'libxrandr' 'jack' 'rubberband' 'uchardet' 'libarchive' 'smbclient'
)
makedepends=('mesa' 'python-docutils' 'ladspa')
optdepends=('youtube-dl: for video-sharing websites playback')
@@ -31,12 +33,12 @@ source=("$_pkgname-$pkgver.tar.gz::https://github.com/mpv-player/$_pkgname/archi
'0001-opengl-backend-support-multiple-backends.patch'
'0002-vaapi-Use-libva2-message-callbacks.patch'
'0003-demux_lavf-return-AVERROR_EOF-on-file-end.patch'
- "http://www.freehackers.org/~tnagy/release/waf-${_waf_version}")
-sha256sums=('341d8bf18b75c1f78d5b681480b5b7f5c8b87d97a0d4f53a5648ede9c219a49c'
+ "https://waf.io/waf-${_waf_version}")
+sha256sums=('836299f1c33c46c8b8615fb84b99ecb05f048431a921e8dc9603aed9eb88af9c'
'609e0530f1b0cdb910dcffb5f62bf55936540e24105ce1b2daf1bd6291a7d58a'
'3c3517f4f4c71e39e1e04ea440688fc8d7b3dc55e6bc0a9398d11a9b75bde07d'
'5de6c616428c87cf9b39d8ba24446d65d175050c083e1054194d93cf03d5816a'
- '01bf2beab2106d1558800c8709bc2c8e496d3da4a2ca343fe091f22fca60c98b')
+ '167dc42bab6d5bd823b798af195420319cb5c9b571e00db7d83df2a0fe1f4dbf')
provides=('mpv')
conflicts=('mpv')
@@ -66,6 +68,7 @@ build() {
--enable-dvb \
--enable-dvdnav \
--enable-encoding \
+ --enable-libsmbclient \
--enable-libarchive \
--enable-libmpv-shared \
--enable-zsh-comp \