summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28222bf0d74e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Peter Züger <zueger.peter@icloud.com>
+
+pkgname=mpy-repl-tool
+_pkgname=mpy-repl-tool
+pkgver=0.10
+pkgrel=1
+pkgdesc="Communicate and transfer files from and to MicroyPython boards via REPL"
+arch=('any')
+url="https://github.com/zsquareplusc/mpy-repl-tool"
+license=('custom')
+makedepends=('python-setuptools')
+depends=(python-pyserial python-colorama)
+optdepends=('python-fusepy: for mounting the micropython filesystem')
+source=(https://files.pythonhosted.org/packages/8d/55/9f37c714fdfab9f591ac4c245910b0dd1c76fd8175935373ff97ec9f884d/${pkgname}-${pkgver}.tar.gz)
+md5sums=('b1ddf7d9620672a206fce499ad2cb5b7')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}"
+ install -Dm644 "LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}