summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 17 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a0e4f0d32045..a05bd626a5c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,27 @@
# Maintainer: Arctic Ice Studio <development@arcticicestudio.com>
# Contributor: Arctic Ice Studio <development@arcticicestudio.com>
+# Maintainer: taotieren <admin@taotieren.com>
+
pkgname=mqttfx-bin
_pkgbasename=mqttfx
pkgver=1.7.1
-pkgrel=1
+pkgrel=4
pkgdesc="A MQTT Client written in Java based on Eclipse Paho"
arch=("x86_64")
url="http://mqttfx.org"
+makedepends=(log4jscanner
+# unzip
+ )
license=("Apache")
options=("!strip")
source=(
- "http://www.jensd.de/apps/${_pkgbasename}/${pkgver}/${_pkgbasename}-${pkgver}-64bit.deb"
+ "https://web.archive.org/web/20210514230412/http://www.jensd.de/apps/${_pkgbasename}/${pkgver}/${_pkgbasename}-${pkgver}-64bit.deb"
"${_pkgbasename}.desktop"
"${_pkgbasename}.png"
)
-sha256sums=(
- "6fb14c739cbf8b54a373a0c5c173ef3657c01c675374ded8f0a292c610e549c2"
- "741674f5b782aa4de0b071b7f49484b74ee2150e38b5d83eb4bd00b172978e2a"
- "6c1b23755d3b1832ddb643b585d623128cde38e2ef42e7839141cf2106b0a59e"
-)
+sha256sums=('6fb14c739cbf8b54a373a0c5c173ef3657c01c675374ded8f0a292c610e549c2'
+ '741674f5b782aa4de0b071b7f49484b74ee2150e38b5d83eb4bd00b172978e2a'
+ '6c1b23755d3b1832ddb643b585d623128cde38e2ef42e7839141cf2106b0a59e')
package() {
local bin_name=MQTTfx
@@ -34,4 +37,11 @@ package() {
# Install the application logo and desktop launcher
install -Dm644 "${_pkgbasename}.png" "${pkgdir}/usr/share/icons/hicolor/128x128/apps/${_pkgbasename}.png"
install -Dm644 "${_pkgbasename}.desktop" "${pkgdir}/usr/share/applications/${_pkgbasename}.desktop"
+
+ # Fix log4j
+ cd "${pkgdir}/opt/${bin_name}/app/"
+# zipinfo lib/log4j-core*.jar | grep Jndi
+ log4jscanner .
+ log4jscanner --rewrite .
+# zipinfo lib/log4j-core*.jar | grep Jndi
}