summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 13 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0e8dab822bf0..b3157dfde456 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mrpt
-pkgver=1.5.5
+pkgver=1.5.6
pkgrel=1
pkgdesc="Provides an extensive set of libraries, algorithms, and applications employed in a number of mobile robotics research areas."
arch=('i686' 'x86_64' 'armv7h')
@@ -14,8 +14,18 @@ install=mrpt.install
_dir=${pkgname}-${pkgver}
_tag=${pkgver}
-source=("${_dir}"::"git+https://github.com/MRPT/mrpt.git"#tag=${_tag})
-md5sums=('SKIP')
+source=("${_dir}"::"git+https://github.com/MRPT/mrpt.git"#tag=${_tag}
+ "https://raw.githubusercontent.com/majorx234/mrpt_patch/master/mrpt_CmakeLists.patch"
+ "https://raw.githubusercontent.com/majorx234/FindNumPy.cmake/master/FindNumPy.cmake")
+md5sums=('SKIP'
+ '4c755c5fecd2f6bca94b02cf2695bcc1c06bd11d34a85f7b2a90bc9f1ebdf4c7'
+ 'e8cbe6841595d594659d9a16464af2386efd0dce2947e8f348e2c47fad1d022f')
+
+prepare() {
+ cp ${srcdir}/FindNumPy.cmake ${srcdir}/$pkgname-$pkgver/cmakemodules/
+ cd "${srcdir}/$pkgname-$pkgver"
+ patch -Np1 -i "${srcdir}/mrpt_CmakeLists.patch"
+}
build() {
# Create build directory