summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 25 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ec07f6dd8fde..34808381c0af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Erik Bročko <erik.brocko@letemsvetemapplem.eu>
pkgname=mshv
-pkgver=258
-pkgrel=4
+pkgver=262
+pkgrel=1
pkgdesc="Amateur radio software by LZ2HV for digital modes MSK, JTMS, FSK, ISCAT, JT6M, FT8/4, JT65, PI4, Q65."
arch=('any')
url="http://lz2hv.org/mshv"
@@ -11,28 +11,40 @@ depends=('fftw' 'alsa-lib' 'libpulse' 'qt5-base' 'qt5-websockets' 'hamradio-menu
makedepends=()
conflicts=('mshv')
provides=('mshv')
+
+# This is suboptimal. But pkgver doesn't seem to get updated soon enough to allow sources to properly download.
+_sfrss="$(curl -s -L "https://sourceforge.net/projects/mshv/rss?path=/")"
+_latestver="$(echo "$_sfrss" | \
+ grep -Poi ' url="https://sourceforge.net/projects/mshv/files/MSHV_\K(\d+)_Full_Source_Code\.zip/download" filesize="\d+"><media:hash algo="md5">([a-fA-F\d]{32})</media:hash></media:content>'\
+ | head -n1 \
+ | cut -d '_' -f 1)"
+_latesthash="$(echo "$_sfrss" | \
+ grep -Poi ' url="https://sourceforge.net/projects/mshv/files/MSHV_(\d+)_Full_Source_Code\.zip/download" filesize="\d+"><media:hash algo="md5">\K([a-fA-F\d]{32})</media:hash></media:content>'\
+ | head -n1 \
+ | cut -d '<' -f 1)"
+
source=(
- "https://downloads.sourceforge.net/project/mshv/MSHV_${pkgver}_Full_Source_Code.zip"
+ "https://downloads.sourceforge.net/project/mshv/MSHV_${_latestver}_Full_Source_Code.zip"
"mshv_launcher.sh"
"mshv.desktop"
- "flrigxml.patch"
- "pa_with_no_alsa.patch"
)
sha256sums=(
- '039c4d432010fdae0805a023960145038c6ae780f7c439d77514aff6cf80cf1d'
+ 'SKIP'
'5ccd21e3d585efb4f37aff8a3470aefa78a8689dad3b00334b9a8467840adbab'
'85c256463746cb8a06ff1eee71677dcbe1d1c54d7aaf0f27156ebe9632269dba'
- '22de199636d17912738651eba8db6b5ccf7cecae816dcddee6d46a33d585f8ca'
- '6d021299b6970e262f73749e2e3b4c859cb5a0f36e19dfd44a0a6924dcc0d7d9'
+)
+md5sums=(
+ "$_latesthash"
+ 'SKIP'
+ 'SKIP'
)
-prepare() {
- patch --directory="$srcdir/MSHV_$pkgver" --forward --strip=1 --input="$srcdir/flrigxml.patch"
- patch --directory="$srcdir/MSHV_$pkgver" --forward --strip=1 --input="$srcdir/pa_with_no_alsa.patch"
+pkgver() {
+ echo "$_latestver"
}
build() {
- cd "$srcdir/MSHV_$pkgver"
+ cd "$srcdir/MSHV_${_latestver}"
# There doesn't seem to be any difference between the .pro files apart from absolute paths
# passed to the linker for some libraries. We'll just rely on ld to find the libraries.
@@ -45,7 +57,7 @@ package() {
install -D -m755 mshv_launcher.sh "$pkgdir/usr/bin/mshv"
install -D -m644 mshv.desktop "$pkgdir/usr/share/applications/mshv.desktop"
- cd "$srcdir/MSHV_$pkgver/bin"
+ cd "$srcdir/MSHV_${_latestver}/bin"
install -D -m755 MSHV_x86_64 "$pkgdir/usr/bin/mshv_bin"
find . -type d -exec install -d -m755 "$pkgdir/usr/share/mshv/"{} \;