summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 27 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c33a9e94735b..e338d0fb6965 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,43 @@
+# Maintainer: Sam L. Yes <samlukeyes123 at gmail dot com>
# Contributor: Andre Klitzing <aklitzing () gmail () com>
pkgname=msitools
-pkgver=0.99
-pkgrel=1
+pkgver=0.101
+pkgrel=5
pkgdesc="Set of programs to inspect and build Windows Installer (.MSI) files"
arch=('i686' 'x86_64')
url="https://wiki.gnome.org/msitools"
-license=('GPL')
+license=('LGPL' 'GPL')
depends=('libgsf' 'gcab')
-makedepends=('intltool' 'vala')
-source=(http://ftp.gnome.org/pub/GNOME/sources/msitools/${pkgver}/${pkgname}-${pkgver}.tar.xz)
-sha256sums=('d475939a5e336b205eb3137bac733de8099bc74829040e065b01b15f6c8b3635')
+makedepends=('intltool' 'vala' 'meson' 'gobject-introspection')
+source=(https://download.gnome.org/sources/msitools/${pkgver}/${pkgname}-${pkgver}.tar.xz
+ $pkgname-glib-2.71.patch::https://gitlab.gnome.org/GNOME/msitools/-/commit/18bc0b2ee79438b8e35c0769165a9a105e3792a0.patch)
+sha256sums=('0cc4d2e0d108fa6f2b4085b9a97dd5bc6d9fcadecdd933f2094f86bafdbe85fe'
+ '8b33b48e8b5a2cb78ea7e2948b8b6b9d264cd1b12c11d3c7870813d6c6a2569e')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -Np1 -i ../$pkgname-glib-2.71.patch
+}
build() {
cd "$srcdir/$pkgname-$pkgver"
- ./configure --prefix=/usr
- sed -i 's|LIBTOOL = $(SHELL) $(top_builddir)/libtool|LIBTOOL = /usr/bin/libtool|g' Makefile
- make
+ arch-meson . build
+ ninja -C build
+}
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ meson test -C build
}
package() {
cd "$srcdir/$pkgname-$pkgver"
- make install DESTDIR="${pkgdir}"
+ DESTDIR="$pkgdir" meson install -C build
+ install -Dm644 copyright "$pkgdir/usr/share/licenses/$pkgname/copyright"
+
+ # Workaround an upstream bug that will be fixed in the next release
+ chmod +x "$pkgdir/usr/bin/msidiff"
+ chmod +x "$pkgdir/usr/bin/msidump"
}