summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 4 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 75e8eb8e9306..53de86361cf3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_target=msp430-elf
pkgname=${_target}-binutils #-git
-_pkgver=2.26.1
+_pkgver=2.27
pkgver=${_pkgver}
#pkgver=2.25.r84308.c576455
pkgrel=1
@@ -12,6 +12,7 @@ options=('!libtool' '!buildflags')
url='http://www.gnu.org/software/binutils/'
license=(GPL)
depends=('zlib' 'flex')
+
# build from trunk
# provides=("${_target}-binutils=${_pkgver}")
# conflicts=("${_target}-binutils")
@@ -20,14 +21,8 @@ depends=('zlib' 'flex')
# sha256sums=('SKIP')
# build from source
-source=(ftp://ftp.gnu.org/gnu/binutils/binutils-${pkgver}.tar.bz2
- dwarf-line-fix.patch
- msp430-dis.c.patch
- update-mcu-list.patch)
-sha256sums=('39c346c87aa4fb14b2f786560aec1d29411b6ec34dce3fe7309fe3dd56949fd8'
- '465964bd2ebf5a7eea340c1e145b3e01bb9da4aa2d9e7d24f8d18a3d2473e2af'
- '0c389f2912d5c860da4f3fd01e589d6da1875582dbca38fde50ae8cd90ab7c79'
- 'cb0eeaa1c4d90c1da5a26827a2c7f379c8572b7f1373f0f5146e6823b53d5ced')
+source=(ftp://ftp.gnu.org/gnu/binutils/binutils-${pkgver}.tar.bz2)
+sha256sums=('369737ce51587f92466041a97ab7d2358c6d9e1b6490b3940eb09fb0a9a6ac88')
# pkgver() {
# cd "${srcdir}/binutils-${_pkgver}"
@@ -38,18 +33,6 @@ sha256sums=('39c346c87aa4fb14b2f786560aec1d29411b6ec34dce3fe7309fe3dd56949fd8'
prepare() {
cd "${srcdir}/binutils-${_pkgver}"
- # the following fixes are scheduled for the 2.27 release
- # fix for
- # https://sourceware.org/ml/binutils/2016-01/msg00299.html
- # found in
- # https://sourceware.org/ml/binutils/2016-01/msg00304.html
- patch -p1 < ../dwarf-line-fix.patch
- # fix for
- # https://sourceware.org/bugzilla/show_bug.cgi?id=20150
- patch -p1 < ../msp430-dis.c.patch
- # updated mcu list
- # https://sourceware.org/ml/binutils/2016-02/msg00243.html
- patch -p1 < ../update-mcu-list.patch
# ensure a clean build
[[ -d binutils-build ]] && rm -rf binutils-build