summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6205e45201b0..0685194614f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@ pkgname=${_target}-binutils #-git
_pkgver=2.25.1
pkgver=${_pkgver}
#pkgver=2.25.r84308.c576455
-pkgrel=2
-pkgdesc="GNU binary utilities for the ${_target} target"
+pkgrel=3
+pkgdesc="GNU binary utilities for the ${_target} target."
arch=(i686 x86_64)
options=('!libtool' '!buildflags')
url='http://www.gnu.org/software/binutils/'
@@ -21,9 +21,11 @@ depends=('zlib' 'flex')
# build from source
source=(ftp://ftp.gnu.org/gnu/binutils/binutils-${pkgver}.tar.bz2
- bfd-fix.patch)
+ bfd-fix.patch
+ tc-msp430.c.patch)
sha256sums=('b5b14added7d78a8d1ca70b5cb75fef57ce2197264f4f5835326b0df22ac9f22'
- '1b5e879dbd9da83a8c7f86abac5cf706b8ba48e3f0525d893a53c651e4015124')
+ '1b5e879dbd9da83a8c7f86abac5cf706b8ba48e3f0525d893a53c651e4015124'
+ 'af639e72b33ce9a6b9f2fcb13355d27d7425f94a6fbefa3d0a377932a6786985')
# pkgver() {
# cd "${srcdir}/binutils-${_pkgver}"
@@ -36,6 +38,11 @@ prepare() {
cd "${srcdir}/binutils-${_pkgver}"
# https://sourceware.org/bugzilla/show_bug.cgi?id=17940
patch -p1 < ../bfd-fix.patch
+ # update list of known MCU names
+ # https://sourceware.org/ml/binutils-cvs/2015-10/msg00074.html
+ # the list has to be in sync with gcc
+ patch -p1 < ../tc-msp430.c.patch
+
# ensure a clean build
[[ -d binutils-build ]] && rm -rf binutils-build
mkdir binutils-build