summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 11 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ae28b4fa724f..309f39e69e9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_target="msp430-elf"
pkgname=${_target}-gcc-stage1
-pkgver=7.2.0
+pkgver=7.3.0
_islver=0.18
pkgrel=1
pkgdesc="The GNU Compiler Collection bootstrap for the ${_target} target."
@@ -12,13 +12,13 @@ url="http://gcc.gnu.org"
depends=("${_target}-binutils>=2.25" 'libmpc' 'elfutils')
options=('staticlibs' '!buildflags' '!libtool' '!emptydirs' 'zipman' 'docs' '!strip')
source=(http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2
- 0001-Use-GET_MODE_BITSIZE-when-setting-TYPE_SIZE.patch
- revert-pr71289.patch
+ 0001-MSP430-Dont-specifically-set-TYPE_SIZE-for-__intN-ty.patch
+ fix-pr79242.patch
ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.xz)
sha256sums=('6b8b0fd7f81d0a957beb3679c81bbb34ccc7568d5682844d8924424a0dadcb1b'
- '28f39dd3ef931d87de1eccf7700406c5b76fa7a6ecf47cfb3f199b33cd1fdf02'
- '836ecb799c88b1c4db7e6ef2df72437a8fe162d1a2d3fb395198fba702f7d9d6'
- '1cf7adf8ff4b5aa49041c8734bbcf1ad18cc4c94d0029aae0f4e48841088479a')
+ '12939e5ba47deecae8c182ad097f7a118c7b70461803b7403b636a18117201f4'
+ '14dcf8903684634f02da4d9bf73f9d93e39db9c07e0e1d2d7d997b5489bc5ada'
+ '832ca6ae04636adbb430e865a1451adf6979ab44ca1c8374f61fba65645ce15c')
prepare() {
# add isl into tree
@@ -30,12 +30,12 @@ prepare() {
[[ -d gcc-build ]] && rm -rf gcc-build
mkdir gcc-build
- # Until pr79242 is resolved, revert pr71289. Yes, the underlying bug is still
- # there, but I do not have the time to investigate it and fix it at the
- # moment. Patches/comments are welcome.
- patch -p1 < ../revert-pr71289.patch
+ # Preliminary fix for pr79242. Without this newlib fails to compile for
+ # MSP430X cores with an ICE. The patch has been around in the GCC mailing
+ # list for a while, not sure why it has not been added to trunk.
+ patch -p1 < ../fix-pr79242.patch
# while we are at it, fix pr78849
- patch -p1 < ../0001-Use-GET_MODE_BITSIZE-when-setting-TYPE_SIZE.patch
+ patch -p1 < ../0001-MSP430-Dont-specifically-set-TYPE_SIZE-for-__intN-ty.patch
}
build() {