summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 5 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 309f39e69e9f..1a35cbf79410 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
_target="msp430-elf"
pkgname=${_target}-gcc-stage1
-pkgver=7.3.0
-_islver=0.18
+pkgver=8.1.0
+_islver=0.19
pkgrel=1
pkgdesc="The GNU Compiler Collection bootstrap for the ${_target} target."
arch=(i686 x86_64)
@@ -11,14 +11,10 @@ license=('GPL' 'LGPL')
url="http://gcc.gnu.org"
depends=("${_target}-binutils>=2.25" 'libmpc' 'elfutils')
options=('staticlibs' '!buildflags' '!libtool' '!emptydirs' 'zipman' 'docs' '!strip')
-source=(http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2
- 0001-MSP430-Dont-specifically-set-TYPE_SIZE-for-__intN-ty.patch
- fix-pr79242.patch
+source=(http://isl.gforge.inria.fr/isl-${_islver}.tar.xz
ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.xz)
-sha256sums=('6b8b0fd7f81d0a957beb3679c81bbb34ccc7568d5682844d8924424a0dadcb1b'
- '12939e5ba47deecae8c182ad097f7a118c7b70461803b7403b636a18117201f4'
- '14dcf8903684634f02da4d9bf73f9d93e39db9c07e0e1d2d7d997b5489bc5ada'
- '832ca6ae04636adbb430e865a1451adf6979ab44ca1c8374f61fba65645ce15c')
+sha256sums=('6d6c1aa00e2a6dfc509fa46d9a9dbe93af0c451e196a670577a148feecf6b8a5'
+ '1d1866f992626e61349a1ccd0b8d5253816222cdc13390dcfaa74b093aa2b153')
prepare() {
# add isl into tree
@@ -29,13 +25,6 @@ prepare() {
# clean build directory
[[ -d gcc-build ]] && rm -rf gcc-build
mkdir gcc-build
-
- # Preliminary fix for pr79242. Without this newlib fails to compile for
- # MSP430X cores with an ICE. The patch has been around in the GCC mailing
- # list for a while, not sure why it has not been added to trunk.
- patch -p1 < ../fix-pr79242.patch
- # while we are at it, fix pr78849
- patch -p1 < ../0001-MSP430-Dont-specifically-set-TYPE_SIZE-for-__intN-ty.patch
}
build() {