summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e3aa3fff642
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=msync-git
+pkgver=0.9.8.r1099.a1132ef
+pkgrel=1
+epoch=
+pkgdesc="A low bandwidth store and forward Mastodon / Pleroma API command line client"
+arch=(any)
+url="https://github.com/Kansattica/msync.git"
+license=('GPL')
+groups=()
+depends=()
+makedepends=(git cmake gcc)
+checkdepends=()
+optdepends=()
+provides=(msync)
+conflicts=(msync)
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+$url")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+pkgver() {
+ cd "$srcdir/msync"
+ printf "0.9.8.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/msync"
+ mkdir -p build
+ cd build
+ cmake .. -DCMAKE_BUILD_TYPE=Release -DMSYNC_BUILD_TESTS=OFF
+ cmake --build . --parallel
+}
+
+package() {
+ cd "$srcdir/msync"
+ install -Dm0755 build/msync "$pkgdir/usr/bin/msync"
+ install -Dm0644 LICENSE "$pkgdir/usr/share/licenses/msync/LICENSE"
+}