summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index be4e5cdd192f..9fc0b63de7ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,16 @@
# Maintainer: Dale Whinham <daleyo at gmail dot com>
pkgname=mt32-pi-control
-pkgver=1.0.0a
+pkgver=1.0.1
pkgrel=1
pkgdesc="A control program for the mt32-pi MIDI synthesizer"
arch=("i686" "x86_64" "armv7h" "aarch64")
url="https://github.com/gmcn42/mt32-pi-control"
license=("BSD")
depends=("alsa-lib")
+optdepends=("bash-completion: for Bash shell auto-completion"
+ "alsa-utils: for auto-completion of the -p option")
source=("https://github.com/gmcn42/mt32-pi-control/archive/v$pkgver.tar.gz")
-sha256sums=("ff86af3b29d814452831b066cde2e47271d658a447e213e56bb4e992f0434a1e")
+sha256sums=("4533941e8baf86b6c293decd62895ca552f4108801b0cb5567725c3ca251b0d9")
build() {
cd "$srcdir"/"$pkgname"-"$pkgver"
@@ -19,6 +21,7 @@ build() {
package() {
cd "$srcdir"/"$pkgname"-"$pkgver"
install -Dm755 linux_bin/mt32-pi-ctl "$pkgdir"/usr/bin/mt32-pi-ctl
+ install -Dm644 linux_src/bash_completion/mt32-pi-ctl.bash "$pkgdir"/usr/share/bash-completion/completions/mt32-pi-ctl
install -Dm644 linux_bin/mt32pi.bmp "$pkgdir"/usr/share/"$pkgname"/mt32pi.bmp
install -m644 README.md "$pkgdir"/usr/share/"$pkgname"/README.md