summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 11 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 63205c8d95b3..0e35ddc99038 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,25 @@
# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
-pkgname=python-pyxel
-pkgver=0.9.4
+pkgname=python-nevergrad
+pkgver=0.1.0
pkgrel=1
-pkgdesc='Retro game development environment'
-arch=('any')
-url='https://github.com/kitao/pyxel'
-license=('MIT')
-depends=('portaudio' 'python-glfw' 'python-numpy' 'python-opengl'
- 'python-pillow' 'python-sounddevice')
-makedepends=('git' 'python-setuptools')
-source=("git+https://github.com/kitao/pyxel#tag=v$pkgver")
+pkgdesc='Gradient-free optimization'
+arch=(any)
+url='https://github.com/facebookresearch/nevergrad'
+license=(MIT)
+depends=(mypy python-bayesian-optimization python-cma python-coverage python-genty python-joblib python-matplotlib python-nose python-nose-timer python-numpy python-pandas python-typing_extensions)
+makedepends=(git)
+source=("git+https://github.com/facebookresearch/nevergrad#tag=v$pkgver")
md5sums=('SKIP')
build() {
- cd pyxel
+ cd nevergrad
python setup.py build
}
package() {
- cd pyxel
+ cd nevergrad
python setup.py install --root="$pkgdir" --optimize=1
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"