summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3c5a2381311e..667d956ba769 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
# Thanks to the maintainers and contributors of the mu binary package
pkgname=mu-git
-pkgver=1.5.8.r5303
+pkgver=1.7.0.r5558
pkgrel=1
epoch=1
pkgdesc="mu and mu4e from git"
arch=('i686' 'x86_64')
url="http://www.djcbsoftware.nl/code/mu"
depends=('xapian-core' 'guile' 'gmime3')
-makedepends=('git')
+makedepends=('git' 'meson')
optdepends=('emacs: mu4e support')
license=('GPL')
provides=('mu')
@@ -21,13 +21,13 @@ md5sums=('SKIP')
pkgver() {
cd mu
- printf %s.r%s $(awk -F, '/AC_INIT/ {print $2}' configure.ac|tr -d \[ | tr -d \]) $(git rev-list --count HEAD)
+ printf %s.r%s $(awk '/version:/ {print $2}' meson.build|head -1|tr -d \' | tr -d \,) $(git rev-list --count HEAD)
}
build() {
cd mu
- ./autogen.sh --prefix=/usr
- make
+ meson build
+ ninja -C build
}
package() {