summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 6 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2b27f921ee16..e353f1d0097d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,17 @@
# Contributor: alicewww <almw at protonmail dot com>
# Contributor: David Birks <david at tellus dot space>
# Contributor: Jeff Henson <jeff at henson dot io>
-# Contributor: Linus Färnstrand <linus at mullvad dot net>
-# Contributor: Emīls Piņķis <emil at mullvad dot net>
-# Contributor: Andrej Mihajlov <and at mullvad dot net>
pkgname=mullvad-vpn
-pkgver=2023.6
+pkgver=2024.1
pkgrel=1
pkgdesc="The Mullvad VPN client app for desktop"
arch=('x86_64')
url="https://www.mullvad.net"
license=('GPL-3.0-or-later')
-depends=('gtk3' 'iputils' 'libnotify' 'nss')
-makedepends=('cargo' 'git' 'go' 'libxcrypt-compat' 'nodejs>=16' 'npm>=8.3' 'protobuf')
-options=('!lto')
+depends=('alsa-lib' 'gtk3' 'iputils' 'libnftnl' 'libnotify' 'nss')
+makedepends=('cargo' 'git' 'go' 'libxcrypt-compat' 'npm' 'protobuf')
install="$pkgname.install"
-_tag=c2f7f75dee35c050540b90c6ebc9084969b1a93b # tags/2023.6^0
+_tag=b261238598f0237aaf420354445797a12a45d907 # tags/2024.1^0
_commit=d5772339cee9c1a0d7671968746f02499b78e245
source=("git+https://github.com/mullvad/mullvadvpn-app.git#commit=${_tag}" # signed by Oskar Nyberg (raksooo), public key not uploaded yet
"git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=${_commit}?signed"
@@ -33,7 +29,7 @@ validpgpkeys=('225E40C8F1C8DEB7977ABF59F293063FECE2E8ED' # Linus Färnstrand <li
)
pkgver() {
- cd "$srcdir/mullvadvpn-app"
+ cd mullvadvpn-app
git describe --tags | sed 's/-/./g'
}
@@ -65,6 +61,7 @@ prepare() {
build() {
cd mullvadvpn-app
+ CFLAGS+=" -ffat-lto-objects"
export CARGO_HOME="$srcdir/cargo-home"
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target