summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 748d7194b9e4..b67f5beba3d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,20 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=mullvad-vpn-beta-bin
-_pkgver=2020.4
-_channel=stable
-pkgver=${_pkgver}.${_channel}
+_pkgver=2020.5
+_channel=beta
+pkgver=${_pkgver}.${_channel}2
pkgrel=1
pkgdesc="The Mullvad VPN client app for desktop (latest/beta release)"
url="https://www.mullvad.net"
arch=('x86_64')
license=('GPL3')
depends=('libnotify' 'libappindicator-gtk3' 'libxss' 'nss')
-optdepends=('bash-completion')
provides=("${pkgname%-beta-bin}")
conflicts=("${pkgname%-beta-bin}")
install="${pkgname%-beta-bin}.install"
-source=("https://github.com/mullvad/mullvadvpn-app/releases/download/${_pkgver}/MullvadVPN-${_pkgver}_amd64.deb"{,.asc}
+source=("https://github.com/mullvad/mullvadvpn-app/releases/download/${_pkgver}-${_channel}2/MullvadVPN-${_pkgver}-${_channel}2_amd64.deb"{,.asc}
"${pkgname%-beta-bin}.sh")
-sha256sums=('997f83a11f91f2be715ed55f02b15057c99ffa1a23df234123712734c543b19f'
+sha256sums=('5b4f49a406d2f0bdbd7777cf6339a6f5688024b6834b982539baea8d0b1dbd56'
'SKIP'
'a59c29f07b4eab9af56f0e8be42bae0d83726f5185e88de0c5a48f4098c3c0a4')
validpgpkeys=('A1198702FC3E0A09A9AE5B75D5A1D4F266DE8DDF') # Mullvad (code signing) <admin at mullvad dot net>
@@ -29,4 +28,7 @@ package() {
# Install daemon service
install -Dm644 "$pkgdir/opt/Mullvad VPN/resources/mullvad-daemon.service" \
"$pkgdir/usr/lib/systemd/system/mullvad-daemon.service"
+
+ mv "$pkgdir/usr/local/share/zsh" "$pkgdir/usr/share"
+ rm -rf "$pkgdir/usr/local"
}