summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 7 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 484e0f4cb262..6e62dfbdbbe8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: John Andrews <theunderdog09 at gmail dot com>
# Contributor: Timo Kramer <fw minus aur at timokramer dot de>
pkgname=mullvad-vpn-cli
-pkgver=2024.1
+pkgver=2024.3
pkgrel=1
pkgdesc="The Mullvad VPN CLI client"
arch=('x86_64')
@@ -13,22 +13,16 @@ makedepends=('cargo' 'git' 'go' 'protobuf')
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
install="${pkgname%-*}.install"
-_tag=b261238598f0237aaf420354445797a12a45d907 # tags/2024.1^0
-_commit=d5772339cee9c1a0d7671968746f02499b78e245
-source=("git+https://github.com/mullvad/mullvadvpn-app.git#commit=${_tag}" # signed by Oskar Nyberg (raksooo), public key not uploaded yet
+_commit=7db2c76522e29b4acd8f461fc87f794954c6df95
+source=("git+https://github.com/mullvad/mullvadvpn-app.git#tag=$pkgver" # signed by Oskar Nyberg (raksooo), public key not uploaded yet
"git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=${_commit}?signed")
-sha256sums=('SKIP'
- 'SKIP')
+sha256sums=('8064e0181b1d30352f25eab563bade47b2fd157ca9646b97aff928241d9870ea'
+ '76015a774788a2274d29e3fa1e06cb752a8488f24a973b5143d8659d5b290e9c')
validpgpkeys=('225E40C8F1C8DEB7977ABF59F293063FECE2E8ED' # Linus Färnstrand <linus@mullvad.net>
'8339C7D2942EB854E3F27CE5AEE9DECFD582E984' # David Lönnhager (code signing) <david.l@mullvad.net>
'4B986EF5222BA1B810230C602F391DE6B00D619C' # Oskar Nyberg (code signing) <oskar@mullvad.net>
)
-pkgver() {
- cd mullvadvpn-app
- git describe --tags | sed 's/-/./g'
-}
-
prepare() {
cd mullvadvpn-app
git submodule init
@@ -92,7 +86,7 @@ build() {
done
echo "Updating relays.json..."
- cargo run --bin relay_list --frozen --release > dist-assets/relays.json
+ cargo run --bin relay_list "${CARGO_ARGS[@]}" > build/relays.json
}
package() {
@@ -115,7 +109,7 @@ package() {
ln -s "/opt/Mullvad VPN/resources/mullvad-problem-report" "$pkgdir/usr/bin/"
# Install relay list
- install -m644 dist-assets/relays.json -t "$pkgdir/opt/Mullvad VPN/resources/"
+ install -m644 build/relays.json -t "$pkgdir/opt/Mullvad VPN/resources/"
# Install OpenVPN certificate
install -m644 dist-assets/ca.crt -t "$pkgdir/opt/Mullvad VPN/resources/"