summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 17 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 908de00c6d44..ea08ddac7f95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: John Andrews <theunderdog09 at gmail dot com>
# Contributor: Timo Kramer <fw minus aur at timokramer dot de>
pkgname=mullvad-vpn-cli
-pkgver=2022.1
+pkgver=2022.2
pkgrel=1
pkgdesc="The Mullvad VPN CLI client"
arch=('x86_64')
@@ -14,11 +14,10 @@ provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
options=('!lto')
install="${pkgname%-*}.install"
-_tag=9797300613176b73497b7c3f090199e1ffe3229b
-_commit=973ee47bec89df537b8ecae20235071055693ec5
+_tag=a66504d6b8cc708a1da4b4e6b40fbe51e9dde4d2 # tags/2022.2^0
+_commit=b63c5c8c7977963aeb585b6ddd4537dffe2aeeec
source=("git+https://github.com/mullvad/mullvadvpn-app.git#commit=${_tag}?signed"
-# "git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=${_commit}?signed"
- "git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=${_commit}" # unverified commit by mvd-ows
+ "git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=${_commit}?signed"
'override.conf')
sha256sums=('SKIP'
'SKIP'
@@ -76,7 +75,7 @@ build() {
export MULLVAD_ADD_MANIFEST="1"
- echo "Building Rust code in release mode using $RUSTC_VERSION..."
+ echo "Building Rust code in release mode using ${RUSTC_VERSION}..."
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
@@ -84,8 +83,8 @@ build() {
mkdir -p dist-assets/shell-completions
for sh in bash zsh fish; do
- echo "Generating shell completion script for $sh..."
- cargo run --bin mullvad --frozen --release -- shell-completions "$sh" \
+ echo "Generating shell completion script for ${sh}..."
+ cargo run --bin mullvad --frozen --release -- shell-completions ${sh} \
dist-assets/shell-completions/
done
@@ -99,14 +98,11 @@ build() {
mullvad-exclude
)
for binary in ${binaries[*]}; do
- cp "target/release/$binary" "dist-assets/$binary"
+ cp target/release/${binary} dist-assets/${binary}
done
echo "Updating relay list..."
cargo run --bin relay_list --frozen --release > dist-assets/relays.json
-
- echo "Updating API address cache..."
- cargo run --bin address_cache --frozen --release > dist-assets/api-ip-address.txt
}
package() {
@@ -114,29 +110,29 @@ package() {
# Install main files
install -d "$pkgdir/opt/$pkgname"
- cp -r dist-assets/* "$pkgdir/opt/$pkgname"
+ cp -r dist-assets/* "$pkgdir/opt/$pkgname/"
# Symlink daemon service to correct directory
install -d "$pkgdir/usr/lib/systemd/system"
ln -s "/opt/$pkgname/linux/mullvad-daemon.service" \
- "$pkgdir/usr/lib/systemd/system"
+ "$pkgdir/usr/lib/systemd/system/"
# Install binaries
- install -Dm755 dist-assets/{mullvad,mullvad-exclude} -t "$pkgdir/usr/bin"
+ install -Dm755 dist-assets/{mullvad,mullvad-exclude} -t "$pkgdir/usr/bin/"
# Link to the problem report binary
ln -s "/opt/$pkgname/resources/mullvad-problem-report" \
"$pkgdir/usr/bin/mullvad-problem-report"
# Install completions
- install -Dm755 dist-assets/shell-completions/mullvad.bash \
+ install -Dm644 dist-assets/shell-completions/mullvad.bash \
"$pkgdir/usr/share/bash-completion/completions/mullvad"
- install -Dm755 dist-assets/shell-completions/_mullvad -t \
- "$pkgdir/usr/share/zsh/site-functions"
- install -Dm755 dist-assets/shell-completions/mullvad.fish -t \
- "$pkgdir/usr/share/fish/vendor_completions.d"
+ install -Dm644 dist-assets/shell-completions/_mullvad -t \
+ "$pkgdir/usr/share/zsh/site-functions/"
+ install -Dm644 dist-assets/shell-completions/mullvad.fish -t \
+ "$pkgdir/usr/share/fish/vendor_completions.d/"
# Install override for daemon
install -Dm644 "$srcdir/override.conf" -t \
- "$pkgdir/etc/systemd/system/mullvad-daemon.service.d"
+ "$pkgdir/etc/systemd/system/mullvad-daemon.service.d/"
}