summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0fa2ad1d9645..908de00c6d44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,10 +14,11 @@ provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
options=('!lto')
install="${pkgname%-*}.install"
+_tag=9797300613176b73497b7c3f090199e1ffe3229b
_commit=973ee47bec89df537b8ecae20235071055693ec5
-source=("git+https://github.com/mullvad/mullvadvpn-app.git#tag=${pkgver}?signed"
+source=("git+https://github.com/mullvad/mullvadvpn-app.git#commit=${_tag}?signed"
# "git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=${_commit}?signed"
- "git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=$_commit" # unverified commit by mvd-ows
+ "git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=${_commit}" # unverified commit by mvd-ows
'override.conf')
sha256sums=('SKIP'
'SKIP'
@@ -27,6 +28,11 @@ validpgpkeys=('EA0A77BF9E115615FC3BD8BC7653B940E494FE87' # Linus Färnstrand (co
'4B986EF5222BA1B810230C602F391DE6B00D619C' # Oskar Nyberg (code signing) <oskar@mullvad.net>
)
+pkgver() {
+ cd "$srcdir/mullvadvpn-app"
+ git describe --tags | sed 's/-/./g'
+}
+
prepare() {
cd "$srcdir/mullvadvpn-app"
git submodule init