summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3e1c82cf1471
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=multiselect
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="multiple x11 selection server"
+arch=('x86_64')
+url="https://github.com/sgerwk/multiselect"
+depends=('libx11' 'libxau' 'libxcb' 'libxdmcp')
+source=(git+https://github.com/sgerwk/multiselect#tag=v$pkgver)
+sha256sums=('SKIP')
+
+build() {
+ cd $startdir/src/$pkgname
+ make || return 1
+}
+
+check() {
+ cd $startdir/src/$pkgname
+ return $(test -x multiselect)
+}
+
+package() {
+ cd $startdir/src/$pkgname
+ make DESTDIR=$startdir/pkg/$pkgname install
+}
+