summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1c0a55d528da..c30b981a7b91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,19 @@
# Maintainer: Michael Taboada <michael@2mb.solutions>
pkgname=munin-libvirt-git
pkgver=r36.e3442fb
-pkgrel=1
+pkgrel=2
pkgdesc="libvirt plugins for munin system monitoring"
arch=(any)
url="https://github.com/MikeQG/munin-libvirt-plugins"
license=('GPL2')
-depends=('munin-node' 'libvirt-python' 'python-lxml')
+depends=('munin-node' 'libvirt-python2' 'python2-lxml')
makedepends=('git' 'pychecker')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=('munin-libvirt::git+https://github.com/MikeQG/munin-libvirt-plugins.git')
-md5sums=('SKIP')
+source=('munin-libvirt::git+https://github.com/MikeQG/munin-libvirt-plugins.git'
+ 'python2.patch')
+md5sums=('SKIP'
+ '80bc3b1a35f821c97ba4f3ab88dbd7e3')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -19,6 +21,11 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ patch -p1 -i ../python2.patch
+}
+
build() {
cd "$srcdir/${pkgname%-git}"
make