summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 13 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d7c5e4d4a01b..7779af8f9276 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,24 +5,26 @@
pkgname=mupdf-git
_pkgname=mupdf
pkgver=20210226.a8f569684
-pkgrel=1
+pkgrel=2
pkgdesc='Lightweight PDF, XPS, and E-book viewer'
arch=('i686' 'x86_64' 'armv7h')
url='https://mupdf.com/'
license=('AGPL3')
-makedepends=('git')
-depends=('freeglut' 'glu' 'harfbuzz' 'jbig2dec' 'libjpeg-turbo' 'openjpeg2')
+makedepends=('git' 'libxi' 'glu')
+depends=('libxrandr' 'harfbuzz' 'jbig2dec' 'libjpeg-turbo' 'openjpeg2' 'gumbo-parser')
source=('git://git.ghostscript.com/mupdf.git'
- 'lcms2::git://git.ghostscript.com/thirdparty-lcms2.git'
'git://git.ghostscript.com/mujs.git'
+ 'git://git.ghostscript.com/thirdparty-lcms2.git'
+ 'git://git.ghostscript.com/thirdparty-freeglut.git'
'desktop')
sha256sums=('SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'3240d4ebda002cb2c4f42cd42793c6160f1701d349d0acb797819dfd10d4fedd')
-conflicts=("${_pkgname}")
-provides=("${_pkgname}")
+conflicts=("${_pkgname}"{,-gl,-tools})
+provides=("${_pkgname}"{,-gl,-tools})
pkgver() {
cd "${srcdir}/${_pkgname}"
@@ -32,16 +34,18 @@ pkgver() {
prepare() {
cd "${srcdir}/${_pkgname}"
- sed "/lcms2.git/c url = $(pwd)/../lcms2" -i .gitmodules
+ sed "/freeglut.git/c url = $(pwd)/../thirdparty-freeglut" -i .gitmodules
+ sed "/lcms2.git/c url = $(pwd)/../thirdparty-lcms2" -i .gitmodules
sed "/mujs.git/c url = $(pwd)/../mujs" -i .gitmodules
+ git submodule update --init thirdparty/freeglut
git submodule update --init thirdparty/lcms2
git submodule update --init thirdparty/mujs
# embedding CJK fonts into binaries is madness...
sed '/TOFU_CJK /c #define TOFU_CJK 1/' -i include/mupdf/fitz/config.h
- # fix memento.h confusion
- echo 'THIRD_CFLAGS += -I./include/mupdf' >> Makethird
+ # force internal freeglut; see e.g. 06c999fec01863a90824ba2f9f3ce98ea1a967d3
+ sed 's/USE_SYSTEM_GLUT :=/& no #/g' -i Makethird
}
build() {