summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index acf1e5ebb79d..8a89195f623b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,22 +4,21 @@
pkgname=mupdf-git
_pkgname=mupdf
-pkgver=20160106.1db0393
+pkgver=20160421.0278606
pkgrel=1
pkgdesc='Lightweight PDF, XPS and CBZ viewer'
arch=('i686' 'x86_64' 'armv7h')
url='http://mupdf.com/'
license=('GPL3')
makedepends=('git')
-depends=('freetype2' 'jbig2dec' 'libjpeg' 'libxext')
+depends=('curl' 'freetype2' 'jbig2dec' 'libjpeg' 'libxext')
source=('git://git.ghostscript.com/mupdf.git'
'desktop')
sha1sums=('SKIP'
'31573e5da3fbf0162c0926511fc9858f2052fa6c')
conflicts=("${_pkgname}")
-provides=("${_pkgname}=1.7.git")
-backup=('usr/bin/mupdf')
+provides=("${_pkgname}")
options=('staticlibs')
pkgver() {
@@ -42,13 +41,17 @@ prepare() {
build() {
cd "${srcdir}/${_pkgname}"
+
make build=release prefix="${pkgdir}"/usr
}
package() {
cd "${srcdir}/${_pkgname}"
+
make build=release prefix="${pkgdir}"/usr install
+ mv "${pkgdir}"/usr/bin/mupdf-x11-curl "${pkgdir}"/usr/bin/mupdf
+ rm "${pkgdir}"/usr/bin/mupdf-x11
+
install -Dm644 ../desktop "${pkgdir}"/usr/share/applications/mupdf.desktop
find "${pkgdir}"/usr/{include,lib,share} -type f | xargs chmod 644
- ln -s mupdf-x11 "${pkgdir}"/usr/bin/mupdf
}