summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2edbb0622582..28f7a072cd04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,6 +10,7 @@ url="https://github.com/ubuntu-flutter-community/musicpod"
license=('GPL3')
depends=('gstreamer' 'gtk3' 'mpv')
makedepends=('clang' 'cmake' 'git' 'ninja')
+checkdepends=('appstream-glib')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=('git+https://github.com/ubuntu-flutter-community/musicpod.git'
@@ -30,6 +31,12 @@ build() {
flutter build linux
}
+check() {
+ cd "${pkgname%-git}"
+ appstream-util validate-relax --nonet "flatpak/${_app_id}.appdata.xml"
+ desktop-file-validate "flatpak/${_app_id}.desktop"
+}
+
package() {
cd "${pkgname%-git}"
install -Dm755 "build/linux/x64/release/bundle/${pkgname%-git}" -t \