summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD58
1 files changed, 41 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b54b24021f43..19c36d0859f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,10 +5,17 @@
# Patched package maintainer: Saren Arterius <saren@wtako.net>
# Patch origin: https://gist.github.com/DeadMetaler/12622bf9415c1100f2d436ffbd6778c6
+### BUILD OPTIONS
+# Set these variables to ANYTHING that is not null to enable them
+
+### Revert offending commit, recommanded to disable if not using NVIDIA
+_revert=1
+
+
pkgname=mutter-781835-workaround
_pkgname=mutter
pkgver=3.30.2+7
-pkgrel=7
+pkgrel=8
pkgdesc="A window manager for GNOME. This package reverts a commit which may causes performance problems for nvidia driver users. Some performance patches also included."
url="https://gitlab.gnome.org/GNOME/mutter"
arch=(x86_64)
@@ -22,12 +29,13 @@ conflicts=(mutter)
groups=(gnome)
_commit=bcd6103c44ff74ebffd1737b8e0f3a952b83bd54 # tags/3.30.2^0
source=("git+https://gitlab.gnome.org/GNOME/mutter.git#commit=$_commit"
- https://gitlab.gnome.org/vanvugt/mutter/commit/fc02b040f3b750b0513f812813351c09795950f6.patch
+ 216.patch 318.patch
https://gitlab.gnome.org/GNOME/mutter/merge_requests/347.patch
startup-notification.patch
revert.patch)
sha256sums=('SKIP'
- 'dffa2ca19281b9fa5a81bf80bd46a8eae78325c7e1f8b2a25c33945aa7cc0903'
+ '1ae59343f3f5838babdfe1400962bb315d8b49189deb05bb516966b922cd26a5'
+ 'd4dcffa9c407e60e321670caaa44dcd6e2bfda7221d73ec4145a985c825a43b3'
'1343ed3c21ca7ab4f179b864eae4b915b910406c3eb8259399973c29822f751c'
'00d5e77c94e83e1987cc443ed7c47303aa33367ce912b2f665bcd34f88890a17'
'2d2e305e0a6cca087bb8164f81bdc0ae7a5ca8e9c13c81d7fd5252eb3563fc09')
@@ -47,20 +55,15 @@ prepare() {
git fetch vanvugt
# clutter: Deliver events sooner when possible
- # https://gitlab.gnome.org/GNOME/mutter/merge_requests/168/commits
+ # https://gitlab.gnome.org/GNOME/mutter/merge_requests/168
# Disabled as may cause stutter when using mouse with high polling rate
# git cherry-pick 7782ed6e
# clutter: Fix offscreen-effect painting of clones
# https://gitlab.gnome.org/GNOME/mutter/merge_requests/117/commits
- git cherry-pick --strategy=recursive -Xtheirs b1493354 || true
+ git cherry-pick 8655bc5d -Xtheirs || true
git rm clutter/tests/conform/meson.build
- git commit -m "fix"
-
- # Sync to the hardware refresh rate, not just 60.00Hz [performance]
- # https://gitlab.gnome.org/GNOME/mutter/merge_requests/171/commits
- git cherry-pick d20697ff
- git cherry-pick 1b310980
+ git commit -m "117"
# Geometric (GPU-less) picking
# https://gitlab.gnome.org/GNOME/mutter/merge_requests/189
@@ -68,21 +71,42 @@ prepare() {
git add -A && git commit -m "347"
# clutter-actor: Add detail to captured-event signal [performance]
- # https://gitlab.gnome.org/GNOME/mutter/merge_requests/283/commits
+ # https://gitlab.gnome.org/GNOME/mutter/merge_requests/283
git cherry-pick 4a9a0d62
# clutter-stage-cogl: Reduce output latency and reduce missed frames too [performance]
# https://gitlab.gnome.org/GNOME/mutter/merge_requests/281/commits
- git cherry-pick 434460c5
- git cherry-pick 13efca15
+ git cherry-pick fc8f80f0^..cfa6bf9d
+
+ # Consolidate all frame throttling into clutter-stage-cogl [performance]
+ # https://gitlab.gnome.org/GNOME/mutter/merge_requests/363
+ git cherry-pick 8c9a6dab^..dcad8363 -Xtheirs
+
+ # clutter: Avoid redundant margin changes
+ # https://gitlab.gnome.org/GNOME/mutter/merge_requests/399
+ git cherry-pick 94cd0246
+
+ # cursor-renderer-native: Floor the cursor position instead of rounding
+ # https://gitlab.gnome.org/GNOME/mutter/merge_requests/353/commits
+ git cherry-pick 8d514095
+
+ # cogl-winsys-glx: Fix frame notification race/leak [performance]
+ # https://gitlab.gnome.org/GNOME/mutter/merge_requests/216
+ git cherry-pick 335993f7
+
# '
# Commented multiline comment end, remove the # above if disabling the patches
- # Revert offending commit, recommended to comment out the line below if not using NVIDIA
- patch -Np1 -i ../revert.patch
+ # Revert offending commit
+ if [ -n "$_revert" ]; then
+ patch -Np1 -i ../revert.patch
+ fi
# https://gitlab.gnome.org/GNOME/mutter/merge_requests/216
- git apply -3 ../fc02b040f3b750b0513f812813351c09795950f6.patch
+ git apply -3 ../216.patch
+
+ # https://gitlab.gnome.org/GNOME/mutter/merge_requests/318
+ git apply -3 ../318.patch
# https://bugs.archlinux.org/task/51940
# As of 2018-05-08: Still needed, according to fmuellner