summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 16 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5aaf35293f0e..533cae25dc76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,18 @@
# Maintainer: Norbert Pfeiler <norbert.pfeiler ät gmail.com>
# Contributor: Christian Assfalg <ch.assfalg_at_gmx_dot_de>
+# Patch by Jan Holthuis
# Also Maintainers and Contributors of the ›mutter‹ package, this package is based on
-pkgname=mutter-catalyst
-pkgver=3.16.2
+_realname=mutter
+pkgname=$_realname-catalyst
+pkgver=3.18.0
pkgrel=1
pkgdesc="A window manager for GNOME with patch for catalyst compatibility"
arch=(i686 x86_64)
license=('GPL')
depends=('clutter'
'dconf'
- 'gobject-introspection'
+ 'gobject-introspection-runtime'
'gsettings-desktop-schemas'
'libcanberra'
'startup-notification'
@@ -19,31 +21,33 @@ depends=('clutter'
'gnome-desktop'
'upower'
'libxkbcommon-x11'
+ 'gnome-settings-daemon'
+ 'libgudev'
)
makedepends=('intltool'
- 'gnome-doc-utils'
'libxkbcommon-x11'
+ 'gobject-introspection'
)
conflicts=('mutter-wayland'
'mutter'
)
replaces=('mutter-wayland')
provides=("mutter=${pkgver}")
-url='http://www.gnome.org'
+url="http://www.gnome.org"
groups=('gnome')
options=('!emptydirs')
install=mutter-catalyst.install
-source=("http://ftp.gnome.org/pub/gnome/sources/mutter/${pkgver:0:4}/mutter-$pkgver.tar.xz"
- 'catalyst-comment.patch' )
-sha256sums=('4a2b752f0b3aa59f50563190222623324f5154acbb6bf174213f5849e77d0763'
- 'fe058744aadcf87cb92a9268beddbb1a501631e02b335a58c593b36c8b47d7d9')
+source=("http://ftp.gnome.org/pub/gnome/sources/$_realname/${pkgver:0:4}/$_realname-$pkgver.tar.xz"
+ 'catalyst-workaround.patch' )
+sha256sums=('9fb287976b9c65f0a2aca09d0e2c4c2748d3d2cfa5f38921dbeafe4cd1d541b1'
+ 'cf6c54cf23dc5898ab105d8bde2d60fd3f6671b319ffef12b0584544bfb23655')
build() {
- cd "mutter-$pkgver"
+ cd "$_realname-$pkgver"
#https://bugzilla.gnome.org/show_bug.cgi?id=741581
echo "Commenting out call to function with XRRChangeOutputProperty to fix issue with catalyst"
- patch -p1 < ../catalyst-comment.patch
+ patch -p1 < ../catalyst-workaround.patch
echo "Patch applied"
./configure --prefix=/usr --sysconfdir=/etc \
@@ -58,6 +62,6 @@ build() {
}
package() {
- cd "mutter-$pkgver"
+ cd "$_realname-$pkgver"
make DESTDIR="$pkgdir" install
}