summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 15499c1e1944..58e823523ea7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,17 +4,17 @@
pkgname=mutter-git
_pkgname=mutter
-pkgver=40.0+2+g9e36ff2dd
+pkgver=40.0+24+ga796edd89
pkgrel=1
pkgdesc="A window manager for GNOME."
url="https://gitlab.gnome.org/GNOME/mutter"
arch=(x86_64)
license=(GPL)
-depends=(dconf gobject-introspection-runtime gsettings-desktop-schemas-git
+depends=(dconf gobject-introspection-runtime gsettings-desktop-schemas
libcanberra startup-notification zenity libsm gnome-desktop upower
libxkbcommon-x11 gnome-settings-daemon libgudev libinput pipewire
- xorg-xwayland graphene)
-makedepends=(gobject-introspection git egl-wayland meson xorg-server sysprof)
+ xorg-xwayland graphene libxkbfile)
+makedepends=(gobject-introspection git egl-wayland meson xorg-server)
provides=(mutter)
conflicts=(mutter)
groups=(gnome)
@@ -29,7 +29,9 @@ pkgver() {
build() {
arch-meson $_pkgname build \
-D egl_device=true \
- -D wayland_eglstream=true
+ -D wayland_eglstream=true \
+ -D installed_tests=false \
+ -D profiler=false
meson compile -C build
}