summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c47631188533..05a1916a6bd0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Joaquim Monteiro <joaquim.monteiro@protonmail.com>
pkgname=mvt
-pkgver=1.0.11
+pkgver=1.0.12
pkgrel=1
pkgdesc="Collection of utilities to simplify and automate the process of gathering forensic traces helpful to identify a potential compromise of Android and iOS devices"
arch=(any)
@@ -9,11 +9,14 @@ url="https://github.com/mvt-project/mvt"
license=('custom')
depends=('libusb' 'python-adb_shell' 'python-biplist' 'python-click' 'python-iosbackup' 'python-libusb1' 'python-rich' 'python-tld' 'python-tqdm' 'python-requests' 'python-simplejson')
makedepends=('python-pip' 'python-setuptools')
-source=("mvt-${pkgver}.tar.gz"::"https://github.com/mvt-project/mvt/archive/refs/tags/v${pkgver}.tar.gz")
-sha512sums=('d711256d3e7d8b863d05fbce07f2c35f9e3e75d63287ce84534de52e13eac1a453d562c5647e8eccde8145eb7546a471e855f2ff93ce60d7e5ed97b65977ff97')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz"
+ 'LICENSE')
+sha512sums=('3f9144484189185e9aa22d5b5eedad1bd86e38872a5062cf645e6294db58311d1074c4a2a2728d4eb91310f6d8a30f3665f0b347710e812a0fd6cab832368a65'
+ 'e6419cdb8af21967a5538d22ed85678e72bdb091768f65ab3d585f9eeec99918a57032eeaede98f3d1fdfb3677ac4fb5af8f2b390a2eaf047186db184936fd5b')
package() {
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
cd "mvt-${pkgver}"
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
python setup.py install --root="$pkgdir" --optimize=1
}